Posted by: oheb | June 21, 2007

The Big Questions…Answered (partially)

1) What’s the deal with ArcGIS Explorer?
I’m not entirely sure. What I’ve gathered so far is this: Explorer is a desktop application that can be customized with your own data, tools, and tasks. To extend it, .NET must be used; Java is not supported. Explorer can consume services from ArcGIS Server, ArcIMS, GeoRSS, etc. It’s a powerful tool, obviously, but some serious discussion would have to happen around whether it’s something that would be useful for us right now.

1) What’s with the Metadata Service in 9.2?
OK, this was a major relief. After questioning many ESRI staff I feel confident that ArcIMS 9.2 DOES, in fact, have a Metadata Service. Yes, that’s right! A Metadata Service exists. What this means is that we can upgrade to ArcGIS 9.2, ArcSDE 9.2, and ArcIMS 9.2 without losing metadata. What does NOT exist is a Metadata Service for ArcGIS Server 9.2, nor will it exist for Server 9.3 (maybe for 9.4?). The reason for this is that a major re-architecture of the catalog system is required to support the ISO 19115 and ISO 19119, for metadata for data and services, respectively. Also note in this OGC Interoperability Matrix that SLD and Catalog 2 support is there for 9.2.

3) Java vs .NET
All aspects of ArcGIS can be extended using either the Java or .NET framework….EXCEPT ArcGIS Explorer and ArcGIS Mobile; any customizations within these frameworks must be done in .NET

4) The IMF
Though I think we currently license the IMF through MoxiMedia, an upgrade to IMF 6.0 would transfer that to GeoCortex in Victoria. The object model for ArcGIS Server is now exposed so customizations can now take place much the same way we currently customize the IMF. More conversation with the GeoCortex people is needed.

TO BE CONTINUED…

Advertisements

Responses

  1. Hi Joel,

    Thanks for the info on the metadata service…can you please find out if the metatdata service from ArcIMS 9.1 or 9.2 can be integrated into an ArcGIS / ArcIMS web mapping application, or will this cause some kind of software conflict?

    thx.

    Dwight

  2. Hey Dwight, we are currently using the ArcIMS 9.1 Metadata Service. If we upgrade to 9.2, we will want to do this for the whole ArcGIS suite; ArcGIS, SDE, and IMS.

    In this scenario, we would be using the SDE component of ArcGIS Server, but not the Web Application component, which would be done through IMS 9.2.

    Email me if more info is required.

    Thanks!

  3. Check out my photos!
    http://picasaweb.google.com/Nonie3234


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Categories

%d bloggers like this: